Android Studioで「Call requires API level ** (current min is **)」なんて出てきたら

Android Studioで開発していると、「Call requires API level ** (current min is **)」

なんて出てくることが、たまにあるのでメモ

出たエラー

私の環境では、こんなのが出ました。

Call requires API level 26 (current min is 19): `android.app.NotificationManager#getNotificationChannel`

通知まわりですね。

同じではなくても、数回同じようなエラーには遭遇しました。

他で発生しても今回の対応方法で、解決できるはずです。

対応方法

Gradle Scriptsの所にある、build.gradle(Module.app)を開いて

minSdkVersionのところの数値を変更します。

私の場合、Call requires API level 26 (current min is 19):

19になってるけど、26以上じゃなきゃダメ!ってことなので、26に変更~

変更したら、エディター上部に、

Gradle files have changed since last project sync. A project sync may be necessary for the IDE to work properly.

と出るので、右に有る Sync Nowの部分をクリック!(これ結構忘れちゃうんですよね。。。)

これでOK。

ぐるぐるビルドが走るので、エラーが消えているか確認してみてください。

関連コンテンツ