Visual Studio Community 2017で “.NETFramework,Version=v4.0” の参照アセンブリが見つかりませんでした

Visual Studio CommunityでDjangoの開発中にエラー発生!解決方法をメモ。

Microsoft Visual Studio Community 2017でPython & Djangoの開発をする事になり、

いざ、Djangoのデバッグしようかと思ったら、、、

こんなエラーが出ました。

debug error

フレームワーク ".NETFramework,Version=v4.0" の参照アセンブリが見つかりませんでした。
これを解決するには、このフレームワーク バージョンの SDK または Targeting Pack を
インストールするか、SDK または Targeting Pack をインストールしているフレームワークの
バージョンにアプリケーションを再ターゲットしてください。
アセンブリはグローバル アセンブリ キャッシュ (GAC) から解決され、
参照アセンブリの代わりに使用されるため、アセンブリが目的のフレームワークに正しく
ターゲットされない場合もあります。

解決方法

解決には該当バージョンの.NET Frameworkをインストールする必要があります。

ツール → ツールと機能を取得

ツールバー

個別のコンポーネントを選択し、

個別のコンポーネント

.NET Framework 4 Targeting Pack にチェックして変更ボタン

.NET Framework 4 Targeting Pack

そうするとインストールが始まります。

Visual Studio Installer

こんなのがでますが、続行をクリック!

開始する前

インストールが終わると、Visual Studioが自動で再起動。

これで無事解決しました。


現場で使える Django の教科書《実践編》 [プリント・レプリカ] Kindle版

関連コンテンツ